Talk:Development: wxMac

From WxWiki
Jump to: navigation, search

I followed the instructions for building for 10.5 and older, but I used:

-isysroot /Developer/SDKs/MacOSX10.4.sdk -mmacosx-version-min=10.4

so that I really can deploy on 10.4.

However, this gives the following error message when running configure --enable-unicode --enable-debug:

checking if CoreFoundation/CFBase.h is usable... no
checking if __CF_USE_FRAMEWORK_INCLUDES__ is required... configure: error: no.  CoreFoundation not available.

If 2.8.10 is not going to work on 10.4, there's not much point in providing the instructions about gcc 4.0. Or did I miss something about building for 10.4?

--Neil Mayhew 21:00, 14 October 2009 (UTC)

After many problems building wxWidgets 2.8.11 on Snow Leopard I found a way to have wxWorking for Mac OS X 10.4 and above for ppc and i386 (can't test this at all, I can only test on 10.5 and 10.6).

./configure CC=gcc-4.0 CXX=g++-4.0 LD=g++-4.0 \
    --with-osx_cocoa --with-opengl --disable-shared --enable-unicode \
    --with-libjpeg=builtin --with-libpng=builtin --with-regex=builtin \
    --with-libtiff=builtin --with-zlib=builtin --with-expat=builtin \
    --enable-universal_binary --with-macosx-version-min=10.4 --with-macosx-sdk=/Developer/SDKs/MacOSX10.5.sdk

-- 09:56, 28 June 2010 (UTC) <>